eee pc glitch

"Please leave a message at the beep, we will get back to you when your support contract expires."

Moderators: phlip, Moderators General, Prelates

Jack Saladin
X is kiss
Posts: 4445
Joined: Thu Jun 15, 2006 8:22 am UTC
Location: Aotearoa

eee pc glitch

Postby Jack Saladin » Thu Mar 26, 2009 3:18 am UTC

So today I started using my eee pc 901, specifically for typing out an essay. I pretty much intend to use it for doing essays and taking notes, so I’m using it entirely for writing. So I open up StarOffice Writer (some sort of rebranding of OpenOffice Writer), and start writing, only to soon encounter a bizzare glitch. After a short period of typing normally, suddenly all the formatting disappeared from my text, and it went into some weird ugly monospaced  font. Any text I typed from that point on would be in that font, no matter what settings I put in (it could say Times New Roman up in the font box and keep on going). Also, keyboard shortcuts stopped working, so pressing ctrl+s just types 's'.

The problem can be fixed by saving, closing Writer, and reopening. But considering how quickly it will happen again (few lines), I end up spending more time dealing with the glitch thanI do on this damn essay.

So I come here, thinking it’s a problem with Writer, and start typing this post, when it friggin' happens in this very text box! Up there, after 'taking notes', the text switched to this other font, and stayed like that down until 'typed from that point on'. Then, oddly enough, it switched back to the regular text for this box, for a few more lines, before going back to the monospace. Then near the start of this paragraph, back to normal.

What the friggin' frig? Evidently something is messed up with Linux, I guess? Anyone ever heard of this? How can I fix it? This laptop is effectively useless if I can't use it for typing.

Screenshot attached.

Edit: Uh, does this post itself look like that for anyone else? 'Cause it actually displays like that on the page for me. Wth.
Attachments
snapshot1.png
snapshot1.png (65.25 KiB) Viewed 1350 times

User avatar
b.i.o
Green is the loneliest number
Posts: 2519
Joined: Fri Jul 27, 2007 4:38 pm UTC
Location: Hong Kong

Re: eee pc glitch

Postby b.i.o » Thu Mar 26, 2009 4:46 am UTC

I can confirm it looks strange for me, too, but I have absolutely no idea what's causing the problem.

If you're so inclined, though, you could ditch the distro that came with it and install another one (eeebuntu, for example), which would probably fix things. (This doesn't seem at all like a hardware problem.)

Other than that I'm no help though, sorry.

User avatar
hotaru
Posts: 1037
Joined: Fri Apr 13, 2007 6:54 pm UTC

Re: eee pc glitch

Postby hotaru » Thu Mar 26, 2009 4:50 am UTC

you're typing fullwidth characters.
i'm guessing you're pressing some button or key combination without realizing it.

Code: Select all

factorial product enumFromTo 1
isPrime n 
factorial (1) `mod== 1

User avatar
phlip
Restorer of Worlds
Posts: 7550
Joined: Sat Sep 23, 2006 3:56 am UTC
Location: Australia
Contact:

Re: eee pc glitch

Postby phlip » Thu Mar 26, 2009 4:54 am UTC

It's switching back and forth between ordinary normal English letters and Fullwidth letters, which are a different Unicode range.

I know my Eee came builtin with Chinese text support... yours probably did too, look in the tray for a button to switch back and forth between Chinese and English. It's possible you're triggering (by accident) some shortcut key to switch from English to Chinese (latin fullwidth) modes, and back.

Code: Select all

enum ಠ_ಠ {°□°╰=1, °Д°╰, ಠ益ಠ╰};
void ┻━┻︵​╰(ಠ_ಠ ⚠) {exit((int)⚠);}
[he/him/his]

User avatar
Gojoe
Posts: 3218
Joined: Wed Apr 30, 2008 12:45 pm UTC
Location: New Zealand!!!

Re: eee pc glitch

Postby Gojoe » Thu Mar 26, 2009 5:20 am UTC

Your post did that as well... I didn't know phpbb worked like that. Learn something new everyday.

I have the first eeepc to come out, I used to use it for typing all the time. And I never had that issue.
michaelandjimi wrote:Oh Mr Gojoe
I won't make fun of your mojo.
Though in this fora I serenade you
I really only do it to aid you.
*Various positive comments on your masculinity
That continue on into infinity*

Feeble accompanying guitar.

User avatar
hotaru
Posts: 1037
Joined: Fri Apr 13, 2007 6:54 pm UTC

Re: eee pc glitch

Postby hotaru » Thu Mar 26, 2009 5:23 am UTC

Gojoe wrote:I didn't know phpbb worked like that. Learn something new everyday.

you thought phpbb went out of it's way to prevent people from using certain unicode characters?

Code: Select all

factorial product enumFromTo 1
isPrime n 
factorial (1) `mod== 1

User avatar
Tricky Zebra
Posts: 1
Joined: Sat Dec 06, 2008 1:33 am UTC

Re: eee pc glitch

Postby Tricky Zebra » Thu Mar 26, 2009 6:37 am UTC

phlip wrote:It's switching back and forth between ordinary normal English letters and Fullwidth letters, which are a different Unicode range.

I know my Eee came builtin with Chinese text support... yours probably did too, look in the tray for a button to switch back and forth between Chinese and English. It's possible you're triggering (by accident) some shortcut key to switch from English to Chinese (latin fullwidth) modes, and back.
I thought I might be pressing something at first, but then it happened when I was definitely just hitting 'f' or whatever. And I know that Chinese shortcut, and it doesn't do that.

Edit: Oh, wrong account, it's TC.

User avatar
Schmendreck
Posts: 197
Joined: Wed Aug 22, 2007 6:18 pm UTC
Location: New York

Re: eee pc glitch

Postby Schmendreck » Thu Mar 26, 2009 2:58 pm UTC

Looks like it happens when you hit "I".
A critic is a person who creates nothing of their own and therefore feels entitled to judge others.
-Robert A. Heinlein

User avatar
Jorpho
Posts: 6185
Joined: Wed Dec 12, 2007 5:31 am UTC
Location: Canada

Re: eee pc glitch

Postby Jorpho » Thu Mar 26, 2009 4:06 pm UTC

I seem to recall the shortcut is something odd, like Shift+Alt - very easy to hit entirely by accident.

If all else fails, you could write your essay in Nano - that doesn't care about unicode, does it?

User avatar
Moo
Oh man! I'm going to be so rebellious! I'm gonna...
Posts: 6370
Joined: Thu Aug 16, 2007 3:15 pm UTC
Location: Beyond the goblin city
Contact:

Re: eee pc glitch

Postby Moo » Thu Mar 26, 2009 4:12 pm UTC

It doesn't seem to happen consistently; perhaps hitting shift to capitalize could be a factor too.

The fact that shortcuts like ctrl+s don't work would seem to indicate another key already being depressed - perhaps not by you but maybe there's something shorting out a key in the keyboard or a key is just stuck?

I don't know the distro so forgive me if this is a stupid suggestion but if it has the equivalent of an onscreen keyboard, bringing that up should show you if it thinks a key is being pressed...
Proverbs 9:7-8 wrote:Anyone who rebukes a mocker will get an insult in return. Anyone who corrects the wicked will get hurt. So don't bother correcting mockers; they will only hate you.
Hawknc wrote:FFT: I didn't realise Proverbs 9:7-8 was the first recorded instance of "haters gonna hate"

User avatar
Yakk
Poster with most posts but no title.
Posts: 11077
Joined: Sat Jan 27, 2007 7:27 pm UTC
Location: E pur si muove

Re: eee pc glitch

Postby Yakk » Thu Mar 26, 2009 6:13 pm UTC

Click on the Input Mode button (set to Chinese by default) will allow you to toggle the Input Mode between Pinyin and English. The keyboard shortcut for this is the left shift key.

So the wonderful people who write IMEs use obscure keys like left shift to toggle between input modes.

(This wasn't from a linux help site...)

Here is a linux SCIM:
https://lists.ubuntu.com/archives/ubunt ... 03511.html
CTRL-SPACE. Assume you have a ctrl key that is screwing up, you could easily execute ctrl-space without knowing it, switch IMEs and then switch back.

Hell -- SHIFT SPACE is also used apparently! So suppose you are going to type a capital letter, and press shift before you get to hitting the space before the letter.... Viola, you have activated SCIM.

Do you use chinese? If not, find a way to disable SCIM. Notice in your post that it is clearing up before capital letters and appearing before capital letters.

Shift-Space is your culprit. (or a shift key that makes your ctrl key stick, then ctrl-space, then it screwing up your ctrl-S shortkeys?)

Jack hiding behind a zebra wrote:And I know that Chinese shortcut, and it doesn't do that.

I'm sorry, I will not trust you if you state "X isn't a problem" unless you give me every single detail about X and every reason why you don't think it is a problem.

Many computer problems reduce to "I didn't plug it in when I thought it was plugged in" among every category of user.
One of the painful things about our time is that those who feel certainty are stupid, and those with any imagination and understanding are filled with doubt and indecision - BR

Last edited by JHVH on Fri Oct 23, 4004 BCE 6:17 pm, edited 6 times in total.

User avatar
Emu*
Posts: 689
Joined: Mon Apr 28, 2008 9:47 am UTC
Location: Cardiff, UK
Contact:

Re: eee pc glitch

Postby Emu* » Thu Mar 26, 2009 10:12 pm UTC

I ditched the default Xandros build from my eee 4G in favour of Ubuntu (Hardy standard, not remix) on Monday night. With an assignment due on tuesday, Synaptic choked on removing the chinese language stuff I was removing to reclaim space. Trying to upgrade everything I could went ok til it tried to remove "asus-i18n-zh-cn", failed, then decided to "undo" everything by removing what it had updated.

...including most of KDE, leaving me with an empty X environment and no TTYs (disabled by default on eees). EPIC FAIL.

Asus's Xandros-eee suffers from a badly specified build, with too much unwanted crap, lots of incorrect dependencies and absolutely no maintenance of their asus packages.
Cosmologicon wrote:Emu* implemented a naive east-first strategy and ran it for an hour, producing results that rivaled many sophisticated strategies, visiting 614 cells. For this, Emu* is awarded Best Deterministic Algorithm!

Jack Saladin
X is kiss
Posts: 4445
Joined: Thu Jun 15, 2006 8:22 am UTC
Location: Aotearoa

Re: eee pc glitch

Postby Jack Saladin » Fri Mar 27, 2009 3:24 am UTC

I'm sorry, I will not trust you if you state "X isn't a problem" unless you give me every single detail about X and every reason why you don't think it is a problem.
Well, the Chinese input shortcut I know about, that's pointed out, involves some obscure key up the top or something (not near my laptop, can't remember specifically), and I know I'm not hitting that. But if it's also shift space or something, that could be it.

So how can I kill this Chinese stuff?

User avatar
Jorpho
Posts: 6185
Joined: Wed Dec 12, 2007 5:31 am UTC
Location: Canada

Re: eee pc glitch

Postby Jorpho » Fri Mar 27, 2009 5:39 am UTC

At least if you mess up Xandros, it's a snap to restore the whole thing back to factory-original conditions. So convenient.

But I too am mystified by the disabling of the Chinese.

User avatar
Yakk
Poster with most posts but no title.
Posts: 11077
Joined: Sat Jan 27, 2007 7:27 pm UTC
Location: E pur si muove

Re: eee pc glitch

Postby Yakk » Fri Mar 27, 2009 2:41 pm UTC

Jack Saladin wrote:
I'm sorry, I will not trust you if you state "X isn't a problem" unless you give me every single detail about X and every reason why you don't think it is a problem.
Well, the Chinese input shortcut I know about, that's pointed out, involves some obscure key up the top or something (not near my laptop, can't remember specifically), and I know I'm not hitting that. But if it's also shift space or something, that could be it.
Test it! See if shift-space or ctrl-space causes you to shift modes.
So how can I kill this Chinese stuff?
Dunno! Neither do I know how to change the config of the Chinese IME so it doesn't do that.
One of the painful things about our time is that those who feel certainty are stupid, and those with any imagination and understanding are filled with doubt and indecision - BR

Last edited by JHVH on Fri Oct 23, 4004 BCE 6:17 pm, edited 6 times in total.

User avatar
Emu*
Posts: 689
Joined: Mon Apr 28, 2008 9:47 am UTC
Location: Cardiff, UK
Contact:

Re: eee pc glitch

Postby Emu* » Fri Mar 27, 2009 6:46 pm UTC

Don't try to remove the other-language files, it'll only end in tears.

You should be able to disable the hotkey though, look for a settings menu item next time you press shift+space.
Cosmologicon wrote:Emu* implemented a naive east-first strategy and ran it for an hour, producing results that rivaled many sophisticated strategies, visiting 614 cells. For this, Emu* is awarded Best Deterministic Algorithm!

Jack Saladin
X is kiss
Posts: 4445
Joined: Thu Jun 15, 2006 8:22 am UTC
Location: Aotearoa

Re: eee pc glitch

Postby Jack Saladin » Sat Mar 28, 2009 12:06 am UTC

Hmm, nope, ctrl+space and shift+space do activate Chinese modes, but they don't cause this problem (they just let me type in Chinese, funnily enough). I went through all of the Chinese input methods (there are a bunch), and none of them caused that.

I really don't think it's a shortcut. I've been pressing a whole bunch of different keys different times it's happened. Any other possibilities?

User avatar
Yakk
Poster with most posts but no title.
Posts: 11077
Joined: Sat Jan 27, 2007 7:27 pm UTC
Location: E pur si muove

Re: eee pc glitch

Postby Yakk » Sat Mar 28, 2009 3:35 am UTC

This is why I think it is related to Chinese IME:
Spoiler:
Jack Saladin wrote:

 

 




 





 








 




 

 







 





These characters seem to be intended for vertical layout. Note how some of the punctuation is centered.

Care to give us information about the Chinese IME you are using? Because currently the guesses are "Chinese IME" or "leprechauns". And the irish don't use monospaced english characters.
One of the painful things about our time is that those who feel certainty are stupid, and those with any imagination and understanding are filled with doubt and indecision - BR

Last edited by JHVH on Fri Oct 23, 4004 BCE 6:17 pm, edited 6 times in total.

User avatar
Jorpho
Posts: 6185
Joined: Wed Dec 12, 2007 5:31 am UTC
Location: Canada

Re: eee pc glitch

Postby Jorpho » Sat Mar 28, 2009 7:52 am UTC

I had another look at my 700 just now and indeed, a bit of random keymashing can result in the text input switching to monospace without changing the input locale indicator in the system tray to something other than EN - although pressing control-space twice does bring things back to normal.

Naturally, right-clicking said indicator just brings up a bunch of unhelpful chinese characters.

Jack Saladin
X is kiss
Posts: 4445
Joined: Thu Jun 15, 2006 8:22 am UTC
Location: Aotearoa

Re: eee pc glitch

Postby Jack Saladin » Sat Mar 28, 2009 7:57 am UTC

Yeah I think ctrl+space does actually switch it back. So it must have something to do with that Chinese stuff.

Also, while ctrl+space and shift+space do usually just switch to Chinese characters, I think under some circumstances they start the monospace text. Not sure what the circumstances are.


Return to “The Help Desk”

Who is online

Users browsing this forum: No registered users and 4 guests